Shared Services has been registered as down
Incident Report for MeenHost
Resolved
This incident has been resolved.
Posted Apr 28, 2023 - 21:21 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 28, 2023 - 21:21 CEST
Monitoring
We seem to have resolved the issue.
Our supplier's data center experienced connectivity issues on an edge firewall.

We will continue to monitor the incident.
Posted Mar 05, 2023 - 16:20 CET
Identified
We located the issue to be at the datacenter.
We've in contact with the datacenter to resolve the issue.
Posted Mar 05, 2023 - 16:18 CET
Update
We're currently investigating periodic outage on two of our EU Budget servers.
Posted Mar 05, 2023 - 11:59 CET
Investigating
We're currently investigating an issue with our shared services.
Posted Mar 05, 2023 - 11:45 CET
This incident affected: Game Servers (EU Budget Servers).